FileMaker 18 Platform Compatibility Update

The FileMaker 18 Platform was released today and we’re pleased to report that all Databuzz products are compatible with the FileMaker 18 Platform. There is one issue that you may encounter related to the installation of plug-ins in FileMaker Pro 18 Advanced depending on the version of the BaseElements plug-in that you have currently installed.

When opening one of our integration solutions in FileMaker Pro 18 Advanced for the first time you will likely encounter one of the following dialog boxes:

There is a new feature in FileMaker Pro 18 Advanced related to the installation of plug-ins: FileMaker Pro 18 Advanced now notifies you when a plug-in has not been digitally signed by its developer. If Set Error Capture is on when the script runs that attempts to install the plug-in you will see the first dialog box, otherwise you will see the 2nd dialog box.

The Get(LastExternalErrorDetail) function has also changed in FileMaker Pro 18 Advanced and now returns information when plug-ins don’t install or load. For example it will return the following immediately after the Install Plug-In File script step has been performed when attempting to install a plug-in has not been digitally signed by its developer:

Plug-in not digitally signed [filemac:/Macintosh HD/Users/andrewduncan/Library/Application Support/FileMaker/FileMaker Pro Advanced/18.0/Extensions/BaseElements.fmplugin/]

If you see the 2nd dialog box you can simply tick the “Always load this plug-in” checkbox, then click the Load Plug-in button to permanently install the plugin and never receive a warning again each time FileMaker Pro 18 Advanced opens. If you would like to update to a digitally signed version of the plug-in we’ve created a simple FileMaker Pro file that you can download here to install a digitally signed version of the BaseElements plug-in. Just download the file, open with FileMaker Pro 18 Advanced and click the Install button to get the digitally signed version of the BaseElements plug-in.

If you’re already using v4.0.5 or higher of the BaseElements plug-in you will not need to do anything as that version has already been digitally signed.

Apart from the issue installing the plug-in for the first time we haven’t encountered any issues with the following products in our testing with the FileMaker 18 Platform:

fmSMS – we have sent messages from multiple SMS Gateways, received replies, checked Account balances and checked the status of sent Messages successfully.

fmAccounting Link (Xero Edition) – we have been able to authenticate, download from Xero to FileMaker and upload from FileMaker to Xero successfully

fmEcommerce Link (WooCommerce Edition) – we have been able to authenticate, download from WooCommerce to FileMaker and upload from FileMaker to WooCommerce successfully

fmEcommerce Link (Shopify Edition) – we have been able to authenticate, download from Shopify to FileMaker and upload from FileMaker to Shopify successfully

fmAccounting Link (MYOB AccountRight Edition) – we have been able to authenticate, download from AccountRight to FileMaker and upload from FileMaker to AccountRight successfully

fmAccounting Link (MYOB Essentials Edition) – we have been able to authenticate, download from MYOB Essentials to FileMaker and upload from FileMaker to MYOB Essentials successfully

We’ve also noticed a nice speed increase when working with the JSON Calculation Functions in FileMaker Pro 18 Advanced which we’ve written about here.

If you encounter any issues with any of our products and FileMaker 18 Platform please let us know. We’ll be writing more articles about some of the new features in the FileMaker 18 Platform over the coming weeks – you can subscribe to our newsletter to be notified when they are released or follow us on Twitter or Facebook.

1 reply

Trackbacks & Pingbacks

  1. […] please to report that all Databuzz products are compatible with the FileMaker 18 […]

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply

Your email address will not be published.